Translating with OmegaT

From Globalsight
Jump to: navigation, search
Translation Wiki
Jump to: Home | Main User Guide
Gs color logo on black bg.jpg
General
About GlobalSight
My Activities | My Account
Translating
Online
Offline
  1. Download the Translation Kit
  2. Translate with:
  3. Upload the translation
Making Review Changes
  1. Accepting the activity
  2. Make review changes:
  3. Complete the activity
Making DTP/LSO Review Changes
Support
Support | FAQs | Training
System Requirements
Logging in
Related Information:








OmegaT is a third-party translation tool. OmegaT is open source and can be downloaded for free from the OmegaT Website.

Note that these instructions do not apply to iOmegaT. iOmegaT is set up and used in a different way.

Watch demo

System Requirements

You must have JRE (Java Runtime Environment) installed to use OmegaT. You are prompted to include JRE as part of the OmegaT installer, if you not have it already.

You can check whether you have Java as described here.

Mac users are not prompted to install JRE. Download JRE from the Java Website, if needed.

Downloading and Installing OmegaT

You can download OmegaT in a number of ways.

The easiest way is to:

  1. Open the OmegaT website
  2. Click Download OmegaT
  3. Click Download Overview
  4. Select the appropriate version for your operating system - for example Windows with JRE - from the Latest versions.
    Note: GlobalSight is configured to work with the latest release of version 3 only, not the standard version
    Trans67.jpg

  5. Save the .exe file that opens from sourceforge.net
  6. Install OmegaT using the default options

You may get errors related to Java not being installed, if you have not yet installed it.

Translating with OmegaT

You can translate offline using OmegaT by:

  1. Downloading the files from GlobalSight in the correct format
  2. Translating offline using OmegaT
  3. Uploading the translated files back into GlobalSight

For more information on using OmegaT in general, see the user guide on the OmegaT website.

Downloading the Files from GlobalSight

The first step is to download the files with the recommended settings from GlobalSight.

The files to be translated are included in a translation kit. You can download single jobs in a single kit or a combined download of several jobs in one translation kit.

To download the translation kit:

  1. Open GlobalSight
  2. Open My Activities and find the activity
  3. Click Work Offline to set your download options
    Trans51.jpg

  4. Set the Format to OmegaT. For details on the other download options, see the Download Options
    Note: The Deny Edit option may not be fully supported. We are investigating
    Myacc09.jpg

  5. Click Start Download
  6. Save the zip file and extract it to a folder on your computer
  7. Click Done

The translation kit for OmegaT contains additional files that are not included with other offline kits.

The file to translate is selected automatically when you open the folder from OmegaT.

Translation kit for OmegaT

Translating offline using OmegaT

To translate using OmegaT:

  1. Open OmegaT
  2. Click Project->Open
    Trans69.jpg

  3. Navigate to the job name folder that shows the OmegaT icon
    Trans70.jpg

  4. Select it and click Open. The Project Files window opens, showing a list of the files for translation and their translation status
    Trans71.jpg

  5. Click Close and start translating
  6. Click Go To to navigate through the segments
    Trans72.jpg

  7. Click View to check the status of the segments
  8. Press Ctrl+T to insert matches. MT matches show as red
  9. Press Ctrl+Space to insert extended characters. Use the arrow keys to select and press Enter
    Trans112.jpg

    • You can customize the list by clicking Options->Auto-completion->Character Table. You can import and export to share with others
      Trans111.jpg

  10. Click Tools->Validate Tags (Ctrl+T) to check that all tags are OK before submitting the translated files
  11. Click Project->Create Translated Documents (Ctrl+D) to generate the file that is uploaded to GlobalSight. The translated files are outputted to the '{project}\target' folder
  12. Click Save and Close
  13. Zip the target folder only and add the job name. For example test_AG_03_21_es_ES_target.zip. The package does not upload successfully if you include any of the other folders in the upload package

You can search and replace by clicking Edit->Search and Replace or Ctrl+K.

Trans108.jpg

Enter the term to search for and click Search. Click Replace to change each instance
Trans110.jpg

The text is replaced. Note that the source text is not changed, but the target text is, even though the match was found in the source. The source does not change.

Trans109.jpg

Note that the search starts again at the beginning without warning. The only way to avoid this is to check the segment ID that shows in the active replace in the main interface and make sure that you are not replacing twice.

Segment IDs iterate sequentially, always starting with the first - <segment 0001> and so on.

Trans117.jpg

Uploading the Files back into GlobalSight

To upload the files:

  1. Open GlobalSight
  2. Open the activity from My Activities
  3. Click Work Offline->Upload
  4. Select the new zip file and click Start Upload
    Trans20.jpg

  5. Check that all files upload successfully
  6. Click Done

FAQs and Troubleshooting

See here.

More Information

For more information on using OmegaT see: